说明: 老家卧室的一台工控机(PVE宿主环境)下运行着黑群晖,家里的弱电箱空间狭小放不了稍大的硬路由器,性能较鸡肋。最后干脆在PVE环境再跑个软路由做旁路网关来分担压力,编译 OPENWRT 固件太耗时,恩山论坛有位网友编译了一个全功能版本的固件,就直接拿来用,本篇文章将记录如何在 Proxmox VE 环境通过虚拟机安装 OpenWrt 配置旁路由的过程,仅做参考。

openwrt-1.jpg

# OPENWRT 镜像下载地址:https://imgs.mpdn.fun:8443/lede/x86_64/
# Plus 版本为功能较多的版本,推荐下载
# 默认账号 root 密码 password
# OPENWRT默认ip 192.168.1.1
# OPENWRT 固件来自恩山论坛用户@bleach1991

# img2kvm 下载地址 http://dl.everun.top/softwares/utilities/img2kvm/img2kvm

PVE创建虚拟机

关于Proxmox VE的安装教程不赘述-> 戳这里

使用 PVE 创建虚拟机,名称(随意),记住你的 VM ID,我这里是 102

image-20210311112754107.png

操作系统 这里选择 - 不使用任何介质

image-20210311112832209.png

设置CPU(请自行根据硬件实际条件进行配置)

image-20210311113313223.png

内存 我给了2G

image-20210311113358154.png

网络设置模型我选择 intel E1000 支持开启千兆全双工

image-20210311113502260.png

没有提到的设置默认就可以了,确认 并创建虚拟机。

image-20210311114014177.png

分离/删除磁盘

创建虚拟机的过程中,自动创建了一块32G的硬盘,要删除此硬盘,则需要先分离硬盘。

image-20210311114320351.png

分离后得到未使用的磁盘进行删除操作,确保当前硬件没有其它磁盘。

image-20210311114411147.png

写入磁盘镜像

解压openwrt-x86-64-generic-squashfs-combined.img.gz后上传 openwrt-x86-64-generic-squashfs-combined.img 镜像文件和img2kvm两个文件到 pve 系统root根目录(可以借助ftp工具或者 rz 命令进行上传)使用。

然后通过 ssh 进入 pve 根目录,运行命令将镜像文件写入到磁盘:

./img2kvm openwrt-x86-64-generic-squashfs-combined.img 102 vm-102-disk-0 

# 命令中 102 为本机 VM id,请修改为你自己的 VM id 

若成功写入磁盘,ssh 终端会出现 Successfully的提示 ,虚拟机会多出一块未使用的磁盘

image-20210311120701138.png

双击这块未使用的磁盘,点击添加。

image-20210311120730311.png

写入磁盘镜像已经完成。

修改网络配置

启动运行虚拟机,进入控制台,当屏幕打印如下图所示信息,按回车键

image-20210311121223174.png

运行命令修改网络配置:

vi /etc/config/network

默认配置如下:

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.1' #默认openwrt ip地址 
    option netmask '255.255.255.0'
    option ip6assign '60'

修改为:

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.0.2' #主路由192.168.0.1,旁路由我设置192.168.0.2
    option netmask '255.255.255.0'
    option ip6assign '60'
    option gateway '192.168.0.1' # 填写为主路由地址
    option dns '114.114.114.114 223.5.5.5' # 正常可用的DNS地址

ESC输入:wq 保存并退出。运行下面命令,重启网络使配置生效,当然你也可以reboot重启openwrt都行:

/etc/init.d/network restart

配置修改 OPENWRT 旁路由 DHCP

完成网络配置,这时候浏览器输入旁路由ip地址 192.168.0.2,输入账号密码可以成功进入。

image-20210311124311147.png

依次点击 网络 - 接口,修改LAN接口设置

image-20210311124505304.png

进入高级设置,勾选动态DHCP强制,填写子网掩码 255.255.255.0

image-20210311124627445.png

其中 DHCP选项 填写格式如下:

3,192.168.0.2 #3,表示设置网关地址选项,192.168.0.2 为旁路由ip
6,192.168.0.2 #6,表示设置DNS服务器地址选项,192.168.0.2 为旁路由ip

关闭/修改主路由 DHCP

要么将主路由 DHCP 关闭,一定要开启DHCP则需要将网关地址和DNS地址填写为旁路由ip地址,然后重启主路由器。(考虑到不同路由器的差异,不一一举例。我用的是梅林固件,我这里选择关闭DHCP)

iShot2021-03-11 18.47.26.jpg

此时,可以通过 OPENWRT 旁路由进行留学、去广告等相关设置。 为所欲为的事情不予细说,各位请自行发挥。


相关推荐

文章作者:喵斯基部落
原文地址:https://www.moewah.com/archives/3643.html
版权声明:本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。非商业转载及引用请注明出处(作者、原文链接),商业转载请联系作者获得授权。