说明: 当我们花了很多米买了群晖NAS或者 DIY 硬件虚拟了黑群晖,就希望将日常的服务统统 ALL IN 梭哈,总想着去榨干硬件的性能。对于群晖 DS920+ 来说,跑一个 OpenWrt 是一件轻松的小事!那么《群晖 VMM 虚拟机安装 OpenWrt 配置旁路由》 这篇文章也就此产生,希望本文记录的过程能给到你一些有用的指引。

openwrt.png

一、前期准备

1.1 OpenWrt 镜像下载

自编译 x86_64 平台的 OpenWrt 镜像 -> 《OpenWrt 编译教程》,或者你也可以直接下载这里推荐的镜像(下载文件到桌面):

# OPENWRT 镜像下载地址:https://imgs.mpdn.fun:8443/lede/x86_64/
# Plus 版本为功能较多的版本,推荐下载
# 默认账号 root 密码 password
# OPENWRT默认ip 192.168.1.1

1.2 安装 Virtual Machine Manager

大部分群晖设备都可以在 套件中心 搜索Virtual Machine Manager安装。

安装 Virtual Machine Manager.png

部分较老旧的设备可下载SPK安装包安装 -> 传送门

1.3 开启 Open vSwitch

进入DSM系统,依次点击 控制面板 - 网络 - 网络界面 - 管理,点击 Open vSwitch 设置,勾选 启用 Open vSwitch

启用 Open vSwitch.png

二、VMM 虚拟机安装 OpenWrt

2.1 上传硬盘镜像

打开 VMM 依次点击 映像 - 硬盘映像 - 新增,选择安装文件这里可以选择 从计算机

上传 OpenWrt 镜像.png

选择准备好的 OpenWrt 镜像文件openwrt-x86-64-generic-squashfs-combined.img进行上传。

如果下载的是.gz压缩文件需要提前解压。Win 系统可以双击压缩包解压,而 Linux / macOS 需要在终端运行 gunzip openwrt-x86-64-generic-squashfs-combined.img.gz 命令解压。

2.2 创建虚拟机

通过硬盘映像来创建虚拟机。步骤:依次点击 虚拟机 - 新增,这里选择 导入,导入方式选择 从硬盘映像导入

导入硬盘映像创建虚拟机.png

点击 下一步,配置常用规格,自定义虚拟机名称、CPUx1 、内存x1GB。CPU配置首选推荐: 启用 CPU 兼容模式,部分黑群晖选择 启用 CPU 兼容模式 可能会导致虚拟机启动失败,遇到这种情况可以改成 Hyper-V 模式。

规格配置.png

继续 下一步 配置 存储空间,选择之前导入硬盘镜像openwrt-x86-64-generic-squashfs-combined.img,为了维护方便 虚拟硬盘控制器 建议勾选 空间回收

存储硬盘.png

继续 下一步 ,开始 配置网络,选择正在使用的网络接口 Default VM Network,并建议将型号设置为 e1000

配置网络接口.png

其它设置:1、建议开启 自动启动;2、指定权限 -> 允许本地用户建议勾选群晖的管理用户。3、勾选 创建后开启虚拟机。最后点击 应用,创建虚拟机。

三、配置旁路由

3.1 修改网络配置

选择正在运行的 OpenWrt 虚拟机,点击 连接 进入OpenWrt 终端

ssh终端.png

当屏幕打印如下图所示信息,按回车键

ssh终端信息.png

运行命令修改网络配置:

vi /etc/config/network

默认配置如下:

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.1' #默认openwrt ip地址
    option netmask '255.255.255.0'
    option ip6assign '60'

修改为:

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.0.2' #主路由192.168.0.1,旁路由我设置192.168.0.2
    option netmask '255.255.255.0'
    option ip6assign '60'
    option gateway '192.168.0.1' # 填写为主路由地址
    option dns '114.114.114.114 223.5.5.5' # 正常可用的DNS地址

ESC 输入:wq 保存并退出。运行下面命令,重启网络使配置生效,当然你也可以 reboot 重启 openwrt 都行:

/etc/init.d/network restart

3.2 配置修改 OPENWRT 旁路由 DHCP

完成网络配置,这时候浏览器输入旁路由 ip 地址 192.168.0.2,输入账号密码可以成功进入。

OpenWrt登录界面.png

依次点击 网络 - 接口,修改 LAN 接口设置

修改lan接口.png

进入高级设置,勾选 动态 DHCP强制,填写子网掩码 255.255.255.0

修改DHCP.png

其中 DHCP 选项 填写格式如下:

3,192.168.0.2 #3,表示设置网关地址选项,192.168.0.2 为旁路由ip
6,192.168.0.2 #6,表示设置DNS服务器地址选项,192.168.0.2 为旁路由ip

3.3 关闭/修改主路由 DHCP

要么将主路由 DHCP 关闭,一定要开启 DHCP 则需要将网关地址和 DNS 地址填写为旁路由 ip 地址,然后重启主路由器。(考虑到不同路由器的差异,不一一举例。我用的是梅林固件,我这里选择关闭 DHCP)

主路由配置.jpg

此时,可以通过 OPEN­WRT 旁路由进行留学、去广告等相关设置。 为所欲为的事情不予细说,各位请自行发挥。


相关推荐

文章作者:喵斯基部落
原文地址:https://www.moewah.com/archives/4697.html
版权声明:本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。非商业转载及引用请注明出处(作者、原文链接),商业转载请联系作者获得授权。